FANDOM


Forums > Senate Hall > SH:General bug thread

We've been listing bugs in the MediaWiki 1.19 thread, but at this point any news bugs are unlikely to be connected to the upgrade, so this thread has been created for general discussion of any bugs that may show up from time to time. Remember that if the bug requires Wikia to fix it, it should probably be reported to Special:Contact/bug, but brief discussion here first may be useful in nailing down whether it only occurs in certain browsers, etc., thereby enabling us to give Wikia more specific information so they can fix it more easily. When reporting a bug, be sure to list your browser version, operating system, and skin, as these may provide useful clues to the problem.

Once a bug has been verified as fixed, it should be archived to Forum:SH:General bug thread/Archive to avoid cluttering the page with stuff that no longer needs attention. If you feel that a bug was prematurely archived and that it has not been fully resolved, feel free to move it back to this page to continue discussion.


Unable to edit Image/File pagesEdit

This is getting to be infuriating. Is there anyone else having difficulty, if not outright inability to edit File: pages? Going on my 4th day now, Wikia/Fandom will not let me add the {{Tumblr}} or {{Cite web}} templates, or any other template for that matter, to any File: page when I'm trying to update the source. It will intermittently allow me to save a plain text addition as a test, but not let me revert the test (I had to get Tope to do it). I have reported the issue to Wikia/Fandom and they have been unable to tell me why. I've used both Firefox and Chrome, running the latest update. I've cleared by browser cache, rebooted my computer, and nothing works. I'm just trying to find out if this is affecting anyone else. - JMAS Jolly Trooper Hey, it's me! 02:39, April 2, 2019 (UTC)

  • You're not tripping any of our abusefilters so that's definitely on Wikia's end. Are you getting some sort of error when trying to save or are the edits simply not getting through? 1358 (Talk) 05:06, April 2, 2019 (UTC)
    • Just a blank white screen in Firefox. And in Chrome, it displays "This page isn't working. starwars.fandom.com is currently unable to handle this request. HTTP ERROR 500" - JMAS Jolly Trooper Hey, it's me! 05:33, April 2, 2019 (UTC)
      • I'm getting the same problem while trying to modify the description and source fields here. When I open up that file page in a new tab to try and start over, I get this purple notification that I've never seen before that says "This is a draft that includes your unpublished changes. Keep up the great work!" with two options to click, either "DISCARD" or "OKAY" -- no matter what I choose, I still get the error page when I do try to save the page. Toprawa and Ralltiir (talk) 21:55, April 2, 2019 (UTC)
        • I'm now getting that same purple notification now. That was not present before. And Fandom is still unable to find any problem. - JMAS Jolly Trooper Hey, it's me! 04:39, April 3, 2019 (UTC)
          • Tope, out of curiousity, are you attempting to add a template as part of your edit? I really feel like this issue revolves around adding templates within the {{Information}} template. If you look at the edit history for File:Bowcaster Wookiee SWL.png, you can see that I was able to save both an edit that closed the Licensing template that I had accidentally left open as well as an edit that simply changed one word for another in the description. But if I try to add the {{Tumblr}} or {{Cite web}} templates, it won't let me. - JMAS Jolly Trooper Hey, it's me! 03:51, April 4, 2019 (UTC)
            • I'm also having this issue when I try adding {{Marvel}} to existing files. I don't encounter any issues when I'm uploading a new image, though. And I've also been getting the purple notification on several pages, file or not. - Cwedin(talk) 03:52, April 11, 2019 (UTC)
              • FWIW, JMAS, I was just trying to add a bare URL to an image source field and still got the draft warning thing Tope described. So it's not just restricted to template usage. Imperators II(Talk) 16:01, April 11, 2019 (UTC)
  • Okay, so, FYI, this edit gives me a 500 error when I try it in Chrome, but it goes through no sweat in AutoWikiBrowser, which edits through the MediaWiki API and not Wikia's kludgy bullshit. Just saying. -- Darth Culator (Talk) 21:08, May 4, 2019 (UTC)
    • I'm having the same URL problem with File:Echo-Base-cutaway-SWCL.png. As soon as I add "https://" to "www.hansjenssen.co.uk/star-wars-locations" I get HTTP ERROR 500. Brules Brules signature Talk 21:28, May 16, 2019 (UTC)
      • Since FANDOM is so completely FUBAR'd and will not let http :// be added, could a solution be to change the templates to pre-insert the http :// so all we have to add is the www.blahblahblah.com? - JMAS Jolly Trooper Hey, it's me! 17:12, May 18, 2019 (UTC)
      • I did update my open support ticket with Fandom support on May 24th with the new information about http being the issue. Same day they reported back that the issue is only affecting Wookieepedia and no other Fandom sites, but I was told this should help them find the problem and fix it. Haven't heard anything since, and shockingly, the issue is still not fixed. - JMAS Jolly Trooper Hey, it's me! 22:13, June 2, 2019 (UTC)

As a hopefully temporary workaround, I've created {{https}} that allows you to add https links without reuploading the entire image. 1358 (Talk) 11:22, August 31, 2019 (UTC)

DEFAULTSORT partly stopped working Edit

The A Crash of Fate article source explicitly lists two categories that the page is a member of (Category:Canon young-adult novels and Category:Star Wars: Galaxy's Edge). The page uses templates that implicitly add it to two further categories (Category:Articles with major spoilers and Category:Real-world articles). The page source includes the text {{DEFAULTSORT:Crash of Fate, A}}, which should (and once upon a time did) correctly alphabetize an article in all its categories. Currently, however, it is correct only in the first two (explicitly listed) categories; in the implicit ones, it is incorrectly filed under A instead of C.

{{DEFAULTSORT}} does not appear to be a Wookieepedia template—the page Template:DEFAULTSORT does not exist here—so this may be a Fandom bug and not a Wookieepedia one, but asking here seems like the best first step. Asithol (talk) 04:08, August 26, 2019 (UTC)

As a point of comparison, I just added {{DEFAULTSORT}} to A Blu Hope!, which is a member of one explicit (Category:Star Wars Insider 128 articles) and two implicit (Category:Magazine article stubs and Category:Real-world articles) categories. This addition alphabetized the article correctly in the explicit category and one of the implicit ones; it remains incorrect in Category:Real-world articles. Asithol (talk) 04:47, August 26, 2019 (UTC)
  • The template responsible for adding Category:Articles with major spoilers has been fixed. The one responsible for Category:Real-world articles will have to be looked at by someone knowledgeable in the Lua language, since that is actually invoked by Module:Eras. Oh, and FWIW, {{DEFAULTSORT}} isn't a template, but rather a "variable". Imperators II(Talk) 09:41, August 26, 2019 (UTC)
    • Module:Eras probably shouldn't categorize articles in Category:Real-world articles, as all real-world articles are already in subcategories of it. Before this edit, neither {{Eras}} or the module did it. On the subject, however, it seems that there's no way to pass {{DEFAULTSORT}} values to Lua modules. 01miki10 Open comlink 10:07, August 26, 2019 (UTC)
      • Yeah, I too had the thought that, at least for these two articles, Category:Real-world articles was redundant with some other category, and I agree with 01miki10 that that should be true in general. So probably the best strategy is reverting that 2016 module edit 01miki10 pointed out. Asithol (talk) 22:11, August 26, 2019 (UTC)
        • I suppose the category is useful in the sense that every single article falls under one of three categories; Canon, Legends, or RL. 1358 (Talk) 23:06, August 30, 2019 (UTC)
          • However, none of IU Legends or Canon articles are in subcategories of Category:Legends or Category:Canon, except the hidden categories for tabs and categories of non-canon articles. 01miki10 Open comlink 11:27, August 31, 2019 (UTC)
            • Right—I wasn't arguing against the usefulness of the Real-world articles category, but rather that placing articles directly within this category violates our rule stating "Articles placed in [a category] should not also be placed in that category's parent category." Real-world articles only exists as a parent category, as every real-world article should be in some subcategory of it. The occasional exception can be specifically added to Category:Real-world articles, but there is no reason that this action should be the default (and in fact was not until 2016, when one editor thought this was somehow "broken"). Asithol (talk) 19:32, September 10, 2019 (UTC)
      • I think I found a way to fix article sorting in all categories added by Module:Eras. Replacing '[[%s:%s|%s]]', 'Category', cat, sort or pagename on line 703 with '[[%s:%s]]', 'Category', cat should do the trick. 01miki10 Open comlink 19:31, September 11, 2019 (UTC)
Community content is available under CC-BY-SA unless otherwise noted.

Build A Star Wars Movie Collection